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Introduzione

Il presente tutorial & destinato agli utilizzatori
del CAD EDA Eagle versione 4, prodotto da
CADSoft.

L'unico prerequisito & che il lettore possieda una
minima familiarita con I'ambiente Eagle, abbia
gia disegnato degli schemi elettrici e dei PCB, e
quindi sia gia in grado di effettuare alcune
operazioni elementari, come l'apertura di un
progetto, la selezione di un elemento,
I'impostazione di un parametro.

Questa succinta trattazione si focalizza infatti

unicamente sulla creazione di una libreria
personalizzata, attraverso I'esempio di
inserimento di  un semplice componente

elettromeccanico. L'intera procedura viene qui
ordinatamente spiegata, passo dopo passo.

Il tutorial & pensato per essere letto e seguito
davanti al terminale, con I'applicativo Eagle in
esecuzione, in modo da poter provare
direttamente le singole operazioni.

Si consiglia caldamente di scaricare e
stampare il manuale di Eagle, disponibile
sul sito CADSoft.

Concetti fondamentali

Eagle &€ un CAD EDA particolarmente incentrato
sulle librerie di componenti.

Le librerie offerte da CADSoft sono molto ricche
e numerose, ed i singoli utenti provvedono ad
arricchire quotidianamente la collezione di
librerie liberamente disponibili sul sito.

Un consiglio importante: studiate a fondo
tutte le librerie disponibili, analizzatele
tramite il browsing del pannello di controllo e
tramite l'editor integrato (non si corre alcun
rischio, anche in caso di modifiche involontarie:
e sufficiente non salvare il file).

Vi & decisamente molto da imparare osservando
con attenzione le soluzioni adottate dai
progettisti CADSoft per trattare i casi piu
complessi (condivisione e riutilizzo dei simboli,
partizionamento logico dei simboli pit complessi,
package disponibili e cosi via) in modo flessibile
ed efficace.

previsti, che occorrera aggiungere manualmente.

Pertanto € necessario acquisire familiarita con la
creazione e la modifica di librerie, al fine di poter
fronteggiare Il'esigenza di gestire  nuovi
componenti (o loro varianti) qualora se ne
presenti la necessita.

Un componente, nelle librerie di Eagle, & una
struttura dati complessa che aggrega uno o piu
simboli (che compariranno nello schematico) e
li associa ad uno o piu footprint (visibili e
gestibili nella fase di creazione del PCB).

I componente viene gestito dall'applicazione
come un unico oggetto, che pud ammettere
varianti, ma solo se debitamente previste in
anticipo nella libreria.

L'associazione tra componente, simbolo/i e
relativo footprint & inoltre alquanto rigida, e non
consente modifiche “al volo” in fase di creazione
del PCB, come invece avviene in altri ambienti
EDA. In fase di creazione del componente, Eagle
non consente di associare simboli e footprint
qualora il numero dei pin del simbolo sia
superiore al numero di pad del footprint.

Superficialmente questo puo apparire
perfettamente consequenziale, ma in realta
esistono casi nei quali una simile violazione
consentirebbe notevoli risparmi di tempo.

Allo stesso modo, non & possibile ottenere
duplicazioni logiche delle funzionalita di un
singolo pin del simbolo, associandolo a piu pin
del package. Eagle ammette, al piu, che un
package possieda dei pad NC.

La relazione d'ordine valida & quindi Pin < Pad.

Le fasi richieste per l'inserimento di un nuovo
componente sono le seguenti:
¢ Creazione o modifica di uno o piu simboli;

¢ Creazione o modifica dei package;
¢ Creazione del componente.

Le prime due fasi possono essere portate a
termine in qualsiasi ordine: sussiste comunque
una interdipendenza tra le due. La fase finale di

creazione del componente deve invece
necessariamente avvenire quando tutti gli
elementi necessari sono disponibili all'interno

della libreria.

Iniziamo dunque ad illustrare le operazioni

Tuttavia, non €& certamente pensabile che le necessarie.

librerie possano contenere “tutto”: vi saranno

sempre alcuni nuovi componenti o package non
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L'ambiente di lavoro

In questo paragrafo si fornisce una rapidissima
descrizione dell'interfaccia utente negli ambienti
di disegno di Eagle, al solo scopo di rendere non
ambiguo il lessico ed i riferimenti utilizzati nel
seguito.
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Gli elementi fondamentali illustrati in figura sono
i seguenti:

1) Toolbar principale, situata nell'area sotto il
menu dell'applicazione. In quest'area
compaiono i comandi essenziali a livello di
file, e le varie toolbar dinamiche legate ai
singoli comandi. Nel seguito utilizzeremo
semplicemente la dicitura toolbar per fare
riferimento all'intera area.

2) Palette dei comandi o “barra laterale”.
Contiene tasti di accesso rapido per quasi tutti
i comandi di disegno ed editing.

3)Command line. In questo campo testuale &
possibile digitare direttamente comandi Eagle,
parametri numerici ed altro. Abituarsi ad
utilizzarla consente enormi risparmi di tempo
rispetto alla gestualita col mouse.

Si rimanda il lettore al manuale di Eagle per
ulteriori approfondimenti.

La creazione di una libreria

La prima operazione da compiere € la creazione
di una nuova libreria.

Cido pud essere fatto molto semplicemente dal
pannello di controllo di Eagle, richiamando il
menu contestuale del progetto corrente con un

ﬁ Close Project ’

| New . [EECIE

Rename Board

Edit Description CAM Job

Lse &l LF

Use none Script
Text
Ealder
Eroject

La medesima funzione &€ anche raggiungibile dal
menu File®New-Library del pannello di
controllo.

Eagle aprira quindi I'editor di libreria. E' possibile
provvedere subito a salvare la nuova libreria, al
momento  vuota, assegnando un nome
significativo. L'operazione & disponibile nel menu
File»Save del library editor.

Un consiglio pratico: hon si lavori mai
direttamente sulle librerie fornite assieme
al CAD (esse variano e vengono aggiornate ad
ogni cambio di versione). E' buona norma
effettuare invece wuna copia di lavoro,
spostandola in una cartella specifica.

E' possibile infatti istruire Eagle a cercare le
librerie ed altri files in directories diverse da
quelle di default: nel pannello di controllo, si
acceda al menu Options-Directories.

Directories @

Libraries

Design Rules

SEAGLEDIR dru

User Language Programs |DADocumenthEDAVULP

Scripts DADocument\EDAVSCR
CAM Jobs DADocurmentiyEDALCAM
Projects DADocurmenthEDALPT

[ [0]4 H Browse ” Cancel ]

I vari percorsi inseriti devono essere separati con
un carattere “;”. La variabile $EAGLEDIR viene
espansa nel percorso di installazione corrente di
Eagle.

Si consiglia inoltre caldamente di effettuare
copie di sicurezza delle librerie prima di iniziare

click destro sul nome del progetto, come | 5 |avorarvi.
mostrato nella seguente figura:
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Eagle effettua comunque dei backup automatici,
con estensione .L#<n>, ove n & un numero
naturale tra 0 e 9 indicante la successione dei
backup.

La prima operazione che vogliamo adesso

compiere & l'inserimento del footprint,
copiandone le dimensioni dal relativo datasheet.

La creazione di un package

Il componente che intendiamo inserire &€ una

presa jack stereo per PCB da 1/4".
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L'operazione da effettuare € quindi la creazione
di un nuovo package. Per questa funzione esiste
scelta

un apposito pulsante di
toolbar:

rapida nella

La funzione €& anche attivabile dal
Library-»>Package.

menu

Eagle chiedera adesso di selezionare un
package, o di crearne uno nuovo digitando un
nome univoco che non sia gia presente
nell'elenco a scorrimento.

*| Edit

Package

Mew: |ACISMC]

Doy J(_exc [ om ]

[ oK H Cancel ]

Nel nostro caso, la libreria non contiene ancora

elementi. Assegnamo un nome affine al codice
del costruttore e confermiamo con OK.

Gli elementi fondamentali per la creazione del
package appartengono a due categorie: i pad,
ovvero le piazzole, e l'ingombro o footprint
propriamente detto, cosi come apparira nella
serigrafia (silkscreen).

Questi elementi appartengono ad almeno due
layer distinti, e vengono gestiti in maniera
separata.

In primo luogo, aggiungiamo i pad necessari.

A volte, nella letteratura dei produttori, viene
presentato il cosiddetto /anding path, ovvero
I'assieme delle forature e delle piazzole, con
relative quote espresse in millimetri o mils
(millesimi di pollice; si ricordi che un pollice
equivale a 25,4 mm).

Nel nostro caso, vista anche la semplicita del
connettore, non & fornito un landing path:
tuttavia, pud essere utile disegnarlo (anche in
modo molto approssimativo, non in scala) su
carta millimetrata o quadrettata, riportando le
varie quote, in modo da svolgere con la
necessaria calma le banali operazioni algebriche
necessarie alla traslazione delle coordinate.

Eagle infatti adotta un sistema di coordinate
cartesiano, con una origine (0,0) e quattro
quadranti.

La scelta della posizione del footprint rispetto
all'origine & dettata unicamente da ragioni di
praticita nella manipolazione del componente
durante la creazione di un PCB.

L'origine & visibile, nella figura seguente, come
una crocetta al centro del componente.

Quello sopra illustrato €& il risultato che ci
prefiggiamo di raggiungere. Analizziamo ora i
passi necessari al suo completamento.

Tutorial: libreria personalizzata
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1) Impostazione della griglia

Il nostro componente & quotato in millimetri.
Sara quindi comodo impostare di conseguenza la
griglia di lavoro.

La finestra di dialogo per l'impostazione dei
parametri di griglia pud essere richiamata
indifferentemente:

— Tramite menu View-Grid...

- Tramite il pulsante di scelta rapida sulla

toolbar

— Con il comando GRID immesso sulla command
line.

Impostiamo quindi la griglia su ON, con passo di
0,5 mm.

Display Style

() off () Dots (@) Lines
hultiple: {1
Alt 0.025 inch v
[ ak. I[ Drefault H Last H Cancel l

2) Inserimento dei pad

i La funzione di inserimento e attivabile
W i¥ tramite il menu Draw-Pad, tramite il
4+ g% pulsante di scelta rapida nella barra
ea g» laterale illustrato nella figura a fianco
i1 & (penultimo pulsante della colonna di
A % sinistra) e con il comando PAD sulla
® command line.

£ F  Una volta attivata la funzione, il che
v viene indicato dalla presenza di un pad
/ T di colore verde (per default) connesso al
O N cursore del mouse, occorre impostare i

parametri del nuovo pad, sulla base delle
indicazioni del datasheet.

La figura seguente mostra |'aspetto della toolbar
per la funzione PAD, dopo le impostazioni
necessarie.

H O oo @ Dameter|254  »|Drill) 15 +| Anglel  »

Abbiamo impostato un pad ottagonale, con
diametro esterno di 2,54 mm e foro da 1,5 mm.

Si noti che il separatore decimale, in Eagle,
segue la convenzione anglosassone ed e
rappresentato da un punto “.”.

Occorre adesso posizionare i pad sulla griglia,
attorno all'origine.

In questa fase & possibile sfruttare le notevoli
potenzialita della command line presente in
Eagle, piuttosto che posizionare manualmente i
pad tramite il mouse.

Si posiziona il cursore del mouse sul campo della
command line, nell'area della command bar, e si
esegue un singolo click.

Si inserisce quindi esattamente il

testo:
(-6.3500 8.2000)
seguito da INVIO.

Eagle posizionera il pad esattamente nel punto
indicato.

seguente

Si procede come sopra per i rimanenti cinque

pad, utilizzando la seguente tabella di
coordinate:
0.0000 8.2000
6.3500 8.2000
-6.3500 -8.2000
0.0000 -8.2000
6.3500 -8.2000

Le coordinate devono essere ovviamente inserite
seguendo la sintassi sopra utilizzata.

A questo punto saranno presenti sei pad,
disposti attorno all'origine come nell'immagine
seguente.

Prima di procedere con il footprint, & essenziale
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assegnare un _nome significativo a ciascun pad.
Cio risultera indispensabile in seguito, per la fase
di associazione dei pin del componente ai vari
pad.

L'attribuzione di un nome ad un elemento fa
capo al comando NAME, attivabile come segue:

— Tramite menu Edit>*Name;

- Tramite I'ottavo pulsante nella colonna di

sinistra della barra strumenti [E
— Digitando NAME sulla command line.

Una volta attivato il comando, ci si posiziona con
il mouse sulla piazzola in _alto a sinistra e si
effettua un singolo click. In tal modo & possibile
assegnare il nome G1 (Ground 1) al pad.

| Name
Mewy name:
=1

[ Ok ] [ Cancel

Al pad corrispondente, in basso a sinistra, si

assegnera quindi il nome G2, ripetendo
I'operazione.
I pad centrali corrispondono al segnale del

canale sinistro (Left), quindi avranno nome L1
(in alto) ed L2. Infine, l'ultima coppia di pad
avra nome R1 (in alto) ed R2, per il canale
destro (Right).

E' essenziale prestare la massima attenzione a
questa fase: infatti, se il componente di cui
discutiamo & decisamente molto semplice, non
puo dirsi altrettanto di integrati SMD con 100 e
piu pin, componenti di potenza o speciali (es.
diodi laser) ed altro. Occorre quindi adoperare
la massima cautela e rimanere concentrati.

Eagle € comunque in grado di fornire aiuto al
progettista per le operazioni di naming piu
complesse, ad esempio tramite gli script e la
funzione di copia con incremento automatico,
che non trovano perd spazio in questa
trattazione introduttiva.

Una volta correttamente assegnati i nomi ai pad,
si pud procedere a disegnare la sagoma
d'ingombro del componente.

3) Creazione del footprint

La sagoma del componente viene disegnata per

mezzo di segmenti e curve tracciati con il
mouse, con l'aiuto della griglia e tenendo
sott'occhio le coordinate correnti. In caso di
necessita, € sempre possibile impostare i punti
da command line, con la sintassi mostrata in
precedenza.

Il comando principale in questa fase € WIRE.

- Menu Draw-Wire;

— Il quinto pulsante dal basso nella colonna di
sinistra;

— Digitando WIRE sulla command line.

Seguendo il datasheet, e preferibilmente con il
componente fisico a portata di mano, si
disegnano le linee principali della sagoma,
aggiungendo alcuni dettagli (senza tuttavia
eccedere in zelo: la serigrafia € un'operazione
che viene svolta con risoluzione limitata).

Le immagini che seguono illustrano varie fasi di
completamente del disegno, volutamente pil
accurato del necessario.

Tutorial: libreria personalizzata
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Occorre solo notare che le linee tracciate devono
appartenere al layer 21 tPlace (il default). Ci si
accerti di questo nel toolbox del comando WIRE,
prima di iniziare a disegnare.

A questo punto, il footprint del nostro connettore
€ quasi terminato.

Occorre solamente aggiungere un elemento
importante, che consente di identificare
visivamente il componente nelle fasi di creazione
del PCB: la sua sigla.

Per questa operazione si utilizza il comando
TEXT (menu Draw=Text), utilizzando pero il

layer 25 tNames e una notazione particolare
per il testo:

>NAME

In questo modo, il CAD inserira in modo

dinamico la sigla del componente.

Ecco dunque I'aspetto finale del package:

Per completare il lavoro, € possibile inserire una
descrizione del package, preferibilmente facendo

riferimento alla letteratura del costruttore.

Nel nostro caso, ci limiteremo ad una descrizione
sommaria, accedendo alla funzione tramite il
menu Edit-»Description.

=|| Description of ACJS-MC
144" (6.3 mm) female PCE jack footprint
14" (6.3 mm) female PCB jack footprint

Headline:

<b>1/4" (6.3 mm) female FCE jack footprint</b>

ok |[ Wndo ] Redo

Cancel

Si noti che Eagle accetta un subset di tag
HTML per la formattazione.

Con questo, la fase di creazione del package puo
considerarsi terminata.

La creazione di un simbolo

Questa fase inizia con la selezione del simbolo su
cui lavorare.

=l Edit

Symbol

Mew: [JACK_MONO|

Dev J[ Pesc ||

Sym |

[ Ok H Cancel l

La finestra di selezione e attivabile dal menu
Library»Symbol, oppure tramite I'apposito
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pulsante di scelta rapida nella toolbar.

s

Nel nostro caso, creiamo il simbolo per un presa
jack monofonica da PCB. In seguito potremo
creare anche il simbolo relativo alla presa
stereo: i due componenti utilizzeranno il
medesimo package, in quanto perfettamente
intercambiabili, a meno dell'omissione dei
collegamenti relativi al canale sinistro.

SO e

Eagle mostrera quindi il designer dei simboli.

Prima di iniziare il disegno, &€ opportuno rendere
visibile il layer 93 Pins. Questo facilitera i
successivi inserimenti.

La selezione dei layer € accessibile tramite menu
View-Display/hide layers... oppure tramite il
secondo speedbutton dall'alto nella colonna
sinistra della barra strumenti.

=l Display B|

Layers:

Mr Marme

Yalues v

] [ Change l l Del ]
[ an ][ Mone |
[ oK I ’ Cancel ]

Il layer prescelto pud essere reso visibile con un
singolo click nella colonna “Nr”, in
corrispondenza del numero del layer desiderato.

In alternativa & possibile eseguire un doppio
click sul nome del layer. Comparira una dialog
box complessa, che consente di impostare tutti i

La figura precedente mostra |'aspetto finale del
simbolo, molto semplice e familiare per chiunque
si sia occupato di apparati audio musicali e PA.

Si inizia il disegno inserendo il rettangolo che
rappresenta l'area del plug, con lo strumento
wire.

Come gia noto, la modalita wire & attivabile nei
seguenti modi:

- Menu Draw-Wire;

— Con il quinto pulsante dal basso nella colonna
di sinistra sulla palette;

— Digitando WIRE sulla command line.

Wlidth:| 10 | S

Impostiamo la griglia a 100 mils e lo spessore di
linea a 10 mils.

B 54 Symbols |

Le linee, in questo caso, devono essere tracciate
nel layer 94 Symbols. Tutte Ile relative
impostazioni sono accessibili nella toolbar
relativa alla modalita WIRE, che appare dopo
I'attivazione.

Si inizia tracciando il contorno del rettangolo che
simboleggia l'area di ingresso del plug, di area 3
x 1 quadretti da 100 mils.

Adesso € possibile selezionare lo strumento di
riempimento rectangle, oppure digitare RECT
sulla command line.

Si proceda riempiendo I'area cosi definita.

parametri del layer stesso, tra i quali

(ovviamente) anche la visibilita.
Si selezioni nuovamente lo strumento wire, e si

\/ proceda alla costruzione delle linee che

rappresentano i contatti di massa e di segnale.
La rappresentazione del contatto sul “polo caldo”
(segnale) puo essere facilitata se si imposta la
griglia sui 50 mils.

Tutorial: libreria personalizzata Eagle 4 EDA Pagina 9 di 13



Si ricorda che anche nell'editor dei package e dei
simboli sono attive le varie modalita di wire
bending proprie di Eagle. Si consulti il relativo
manuale per approfondimenti.

| ol e Y

Una volta terminato il disegnho simbolico, occorre
aggiungere gli elementi pit importanti, ovvero i
pin che rappresentano i punti di connessione per
i segnali elettrici.

I pin vengono gestiti come segue:

— Con l'ultimo pulsante in basso nella colonna di
sinistra sulla palette;
- Digitando PIN sulla command line.

Una volta attivato il
parametri dei pin:

comando, impostiamo i

Si seleziona innanzi tutto la lunghezza “point”.

Opzionalmente, & possibile impostare anche la
“direzione” del segnale per il controllo elettrico
ERC, cambiando dal default I/O a PAS (passive).

Direction:) Pas |«

Cio, tuttavia, non & strettamente necessario.

A questo punto, si avra un pin rappresentato da
un circolo in colore verde, che segue il cursore
del mouse.

Occorre adesso ricordare che il footprint inserito
possiede una coppia di pad per ciascun segnale.
Sebbene sia possibile abilitare un singolo pad,
cio potrebbe risultare poco pratico; d'altro canto,
Eagle non consente di assegnare un singolo pin
a due o pilu pad.

Per ovviare a questo inconveniente,
prevederemo nel simbolo (contrariamente alle
normali abitudini invalse !) due pin per ciascun
segnale.

Per quanto attiene la disposizione, sono possibili
almeno un paio di alternative.

La prima soluzione prevede la sovrapposizione
in linea dei pin. Si tratta della rappresentazione
utilizzata, ad esempio, nella libreria dei DC-DC

converter. Cid0 che si ottiene € una
rappresentazione elegante e piu affine alle
consuetudini asseverate, ma occorrera poi porre
attenzione, ogni volta che si utilizza il simbolo in
uno schema, a connettere propriamente tutti i
pin con il relativo “wire” di segnale,
prolungandolo fin dove necessario.

L'altra opzione prevede invece lo sdoppiamento
dei pin. L'aspetto esteriore del simbolo diventa
certamente meno elegante, ma in questo modo
si ha una maggiore intuitivita delle connessioni a
design time.

La figura che segue mostra un esempio della
prima disposizione:

1/0 %@O %

Qui si comprende meglio la necessita di rendere
visibile il layer 93 Pins.

/\f}/ 0 ©
\__/
1/0 0
\ /J

S

~1/0 O

)

~1/0 ©

N

La figura mostra invece la rappresentazione
alternativa, con i pin non allineati.

Si lascia al gusto estetico ed alle preferenze del
lettore la scelta definitiva, ricordando che nelle
librerie predefinite la prima soluzione compare
piu frequentemente.

Quale che sia la disposizione scelta, occorre
assegnare a ciasun pin un nome univoco.

Nel nostro caso,
rappresentazione del
seguenti denominazioni:

R1, R2 (Right) per il segnale, corrispondente ai
pin piu in alto;

per coerenza con la
package, scegliamo le

Pagina 10 di 13

Eagle 4 EDA

Tutorial: libreria personalizzata



G1l, G2 (GND) per la massa di segnale, che
corrisponde alla linea di base del simbolo.

Come gia noto, il comando NAME si attiva:
— Tramite menu Edit>Name;

- Tramite I'ottavo pulsante nella colonna di

sinistra della barra strumenti
— Digitando NAME sulla command line.

Una volta attivato il comando, ci si posiziona con
il mouse sulla circonferenza verde in basso,
all'estrema destra e si effettua un singolo click.
In tal modo €& possibile assegnare il nome G1
(Ground 1) al pin. Si procede allo stesso modo
per gli altri pin.

Al termine di queste operazioni, rimane
necessario unicamente impostare la collocazione
della sigla del componente, e dell'eventuale
campo Value (contenente il codice commerciale
0 analogo riferimento).

Queste operazioni, come gia noto dalla fase di
creazione del package, vengono svolte
posizionando del testo (formattato in modo
specifico) sui layer di competenza, che sono
rispettivamente 95 Names e 96 Values nel caso
del simbolo.

Le stringhe da inserire sono:

>NAME

per la sigla, e

>VALUE

per il campo dati relativo al componente.

L'aspetto finale sara quindi il seguente:

>NAME
L 1/0 0~ ~1/0 @
N

‘\/—CTCU

1/0 6~ ~1I/0 ©
NN

>UALUE

E' adesso possibile inserire anche wuna
descrizione per il simbolo, sebbene cid6 non sia
strettamente necessario.

La creazione del componente

Una volta resi disponibili, all'interno della
libreria, un simbolo ed un package, si deve
procedere alla creazione del componente.

L'operazione ha inizio dal menu
Library-»>Device, oppure tramite I'apposito
pulsante di scelta rapida.

B3|

:[}-
Si imposta quindi il nome del nuovo device,

coma da codice costruttore:

| Edit X
Device
Mew: | ACIM|
Dew ] [ Fac ] [ S l
[ 0K ] [ Cancel l

Eagle attivera quindi il device editor.

Come prima operazione, utilizzando il comando
ADD, si aggiunge il simbolo appena creato.

£l Add X

(0] l ’ Cancel
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Il comando ADD ¢ attivabile nei seguenti modi:
— Tramite menu Edit>Add;
— Tramite l'ultimo pulsante nella colonna di

destra della barra strumenti (%
- Digitando ADD sulla command line.

cliccando in
riqguadro a

Si inserisce il simbolo
corrispondenza dell'origine, nel
sinistra dell'editor.

Adesso occorre associare il simbolo ad un
footprint. Per fare cio, si clicca sul pulsante
“New” in basso, al centro della schermata.

[ Chiew J[

( Frefix 4

Yalue

Si apre una finestra di selezione, che contiene
tutti i packages presenti in libreria (nel nostro
caso, uno).

=l Create new package variant for ... E|

Fackages
ACIS-MC

1/4" (6.35mm) stereo PCB
female jack footprint

Yariant narme

1
* |

Ok H Cancel ]

Dopo avere selezionato il footprint, occorre
digitare nel riquadro evidenziato in rosso il nome
della variante (essenziale per i componenti che
ammettono pit di un package). Nel nostro caso,
il nome della variante (che viene postfisso al
valore del componente nello schema) sara una
stringa vuota: occorre pertanto digitare una
coppia di apici singoli <'> per imporre ad Eagle
di accettare la stringa nulla, come ben visibile in
figura.

Si conferma la selezione con OK.

E' necessario adesso procedere con
I'associazione tra i pin del simbolo ed i pad del
footprint, operazione delicata - in special modo
per i componenti pit complessi.

Per fare cio occorre un click sul tasto “Connect”,
a destra del tasto "New”, oppure un doppio click
sul nome del package presente nella finestra
inferiore della zona destra della schermata.

Si apre una dialog box complessa, suddivisa in
tre elenchi principali, che mostrano
rispettivamente i pin del componente (“Pin”, a
sinistra), i pad del footprint (“Pad”, al centro) e
I'elenco delle associazioni (“Connection”, a
destra).

%) Connect " (ACJS-MC) 3
Bin Pad Erpeetan
Narme MName Pin Pad
Gi1.G1

G§1.G2 G2

GHRT L1

GH1R2 L2

Connect . Il Disconnect ]

Copy frofm

L'operativita & molto semplice:

— Si seleziona un pin nella lista di sinistra, con
un singolo click;

— Si seleziona il pad corrispondente nella lista
centrale, con un singolo click;

- Si  effettua infine un click sul
“Connect”, in basso a sinistra.

pulsante

Esistono anche delle scorciatoie, come & facile
attendersi: ad esempio, un doppio click su un
pin 0 su un pad provoca l'associazione
immediata, rispettivamente, con il pad o il pin
correntemente selezionato nell'altra finestra.

La coppia cosi selezionata verra aggiunta alla
finestra di sinistra. Si consiglia di ordinare la
lista delle associazioni per pad, crescente:
questa sana abitudine sara utilissima per
I'immissione di circuiti integrati con package ad
elevato pin count, ad esempio. L'ordinamento
puod essere variato con un singolo click sul nome
della colonna.

La finestra presenta inoltre opzioni avanzate,
come la copia della lista di associazione da un
altro package gia associato al simbolo, nel
contesto del medesimo componente (device).
Nel nostro caso tale caratteristica non sara
sfruttata, ma & essenziale conoscerne le
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potenzialita.

Al termine del lavoro, la finestra di dialogo dovra
avere il seguente aspetto:

2l Connect " (ACJS-MC) 3]
PBin Pad Carnection

Mame MNarme Pin Pad

L2 G§1.G2 G2
G$1R1 R1
G$1R2 R2

Connect ] ( Disconnect ]

Copy from:

o=

I pin ed i pad con il medesimo nome (G1, G2,
R1, R2) dovranno risultare ordinatamente
accoppiati. Si noti che rimangono dei pad non
connessi, nella finestra centrale: Eagle considera
tale situazione coerente e perfettamente
accettabile.

E' adesso possibile confermare con OK e tornare
alla schermata principale dell'editor.

Adesso occorre impostare il prefisso (prefix) con
il quale desideriamo che il componente sia
contrassegnato nello schema elettrico e nel
layout. L'identificativo utilizzato da Eagle e
infatti composto da una parte alfabetica fissa,

secondo il tipo di componente (es. “IC”, “TR”,

“D”, "R”, *C"...) e da una parte numerica, gestita
dal CAD tramite la numerazione automatica in
fase di inserimento e la rinumerazione tramite
comandi di script.

Si effettua un click sul tasto “Prefix”, situato
subito sotto il tasto “New”, e si assegna come
prefisso “3".

Poiché non ci interessa far comparire il codice
commerciale del componente nella serigrafia,
lasciamo il radiobox “Value” su “Off”.

Aggiungiamo una descrizione sommaria del
componente, tramite il menu
Edit>Description. Poiché questa descrizione
apparira nel BOM (Bill Of Materials, ossia I'elenco
componenti) & sensato inserire qui il codice
commerciale del costruttore, assieme ad una
descrizione esplicativa.

A questo punto non rimane altro che salvare la
libreria, tramite I|'apposita opzione di menu
File»Save, e quindi uscire.

Il componente denominato “ACIM”, presa jack
per PCB, & ora pronto per l'utilizzo nei nostri
schemi e relativi circuiti stampati, nello stesso
identico modo in cui utilizziamo i componenti
standard contenuti nelle librerie originali del CAD
EDA Eagle.

2l 3 Library - D:ADocumenti\EDANPrj\Guitar\Distortionicon-guitar. lbr (ACJM. dev)
Eile Edit Draw ¥iew Lbrary Options Window Help

female jack
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